RSS

How to create Users and Groups in OBIEE11g

03 Dec

Steps to Create a User and Group:

If you want to create a new User and assign that User to a new Group that you have created, do the following:

  1. Launch Weblogic Administration Console eg: http:<hostname>:<port_no>/console
  2. Create a new User in security Realm.
  3. Create a new Group in security Realm.
  4. Add User to new Group.
  5. Launch Fusion Middleware EM console (http:<hostname>:<port_no>/em)and create a new Application Role and assign it to the new Group.
  6. Edit the repository (RPD file) and set up the privileges for the new Application.

2. Create a new User in security Realm:

Login Weblogic admin console and on Left side panel click on Security Realm1 . And click on myrealm2 in Right side panel.

Click on Users and Groups Tab and below select Users tab again and then click New as shown in below screen shot.

Create user by providing all details and click ok.

3. Create a new Group in security Realm:

Login Weblogic admin console and on Left side panel click on Security Realm1 . And click on myrealm2 in Right side panel.

Click on Users and Groups Tab and below select Groups tab again and then click New as shown in below screen shot.

Create a Group by providing all details and click ok.

4. Add User to new Group.

Click on Security ream->myrealm.

And then click on Users and Groups and Users tab. In that click on new user (here User1 )

In Next window click on Groups. In Available Groups select created group and Move to chosen window as shown below.

5. Launch Fusion Middleware EM console (http:<hostname>:<port_no>/em)and create a new Application Role and assign it to the new Group:

Assign Group to Application Role:


Important:  Stop OPMN and Start again

6. Edit the online repository (RPD file) and set up the privileges for the new Application:

Click on Manage->Identity

Click on BI Repository and on Right window clicking on Application Roles – Now you can see roles created in EM Console.




Thanks,
Shiva

Advertisements
 
14 Comments

Posted by on December 3, 2010 in OBI EE, OBIEE 11g

 

14 responses to “How to create Users and Groups in OBIEE11g

  1. Ravi

    December 10, 2010 at 3:39 pm

    Hi,
    I tried the steps explained in oracel by example document to import the FMW users, from there on i am unable to login using WEBLOGIC user through BI analytics and Admin tool, got following error

    nqsError:13041 the guid of user weblogic does not match user refernece GUID at the repositiory. please ask the administrator to delete the old user reference at the repository and login again

    On viewing couple of notes in forum i changed the FMW_UPDATE_ROLE_AND_USER_REF_GUIDS =YES (NQSConfig.INI )and included below UpdateAndExit (instanceconfig.xml). Restarted,
    1) Managed process
    2) Bi_server
    3) Weblogic server

    Still i am unable to login as weblogic user, please help me !!

    Thanks

     
    • Shiva Molabanti

      December 12, 2010 at 7:10 pm

      Hi Ravi,
      Delete your weblogic user and recreate again in weblogic Admin Console.

      Thanks,
      Shiva Molabanti

       
  2. ravi shankar

    December 16, 2010 at 5:13 am

    hi,
    Thank you for your reply…i am still getting same error message even after deleting and re-creating the weblogic user.

    Thanks

     
  3. Ravikumar

    December 20, 2010 at 3:25 pm

    Hello,

    I am new to 11G aswell as customization Can anyone help how to set the properties for chart view with below values:

    1 Background
     Color Grey (#EEEEEE)
     Text Color = Black (#000000)

    2 Legend
     Location = At the bottom
     Color = Black (#000000)
     Style = Bold

    3 Axis Titles & Labels
     Labels : Color = Black (#000000) and Style = Bold
     Title : Color = Black (#000000) and Style = Bold

    4 Lines
     Type = Plain
     Width (Px) = 2

     
  4. Rohit

    December 22, 2010 at 10:33 pm

    Hi Shiva neatly presented, It works well, I have a question as to how you migrate the users/groups created over to Testing/Production?
    Or is it possible to create/update users/groups via a script?

     
  5. srikanth

    March 7, 2011 at 6:13 am

    hi shiva,

    The above steps you have explained very neatly,it worked very well i am new to Obiee11g but now i am able to create users&user Groups in obiee11g.

    Thanks

     
  6. Dave H.

    July 13, 2011 at 2:50 pm

    Thanks, Shiva. Restarting OPMN after making the changes in the EM console was the key step that I was missing. Otherwise, I could not see my new Application Roles within the BI Admin tool. I really appreciate your post, as it saved me many hours of troubleshooting.

    Keep up the great work!

    -Dave

     
  7. Kumar

    October 7, 2011 at 12:16 pm

    Hi Shiva,

    we had a requirement to move the Application Roles & Policies form one environment to another (Weblogic server) ,
    Please help us on it.

     
  8. Samita

    October 14, 2011 at 6:14 am

    Hi,
    Thanks for the post.
    But i have one issue. i have created two groups(say group1, group2) fro console and added those groups in em>security>application roles.
    now i have also created one user(user1). when i assign the user to group1 OR group2 then it works fine for the roles associated with these groups(say report 1 for group1 and report2 for group2). but if i assign both the groups to user1 then after login to analytics with user1 credential i am unable to view any of the reports.. please help

    thanks in adv.
    Samita

     
  9. Ayyappan

    January 3, 2012 at 3:37 pm

    Hi i am new to obiee…Can u please give the steps to enable proxy functionality in obiee 11.1.1.5..

     
  10. Ivana

    January 11, 2012 at 1:46 pm

    Why can’t we see User in Admin Tool (in Identity) that we have created in Web Logic? We can see Application Role that we have created and user in that role, but we do not see user under User tab.

     
  11. ramesh

    December 27, 2012 at 1:23 pm

    Hi shiva,i need obiee 10g steps for creating user and groups

     
  12. adii

    October 10, 2014 at 6:51 am

    hi i have a issue in console ,i have given the provider as oracle corp oid instead of default authenticator ,im not getting the option to add a user to the group.for the default authenticator provider only it showing that option.any one please help to resolve this issue…..thank you…..

     

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: